Hauptmenü  

   

Elektronik  

   

Login  

   

Beitragsseiten

Gewitter Sensor AS3935 von AMS

Durch Zufall bin ich auf einen Chip gestoßen, der Gewitter in einem Radius von 40Km erkennt und somit bei nahenden Gewittern zur Vorwarnung dienen kann. Laut dem Datenblatt des Herstellers hat der Chip folgende Merkmale:

  • Warnung vor Gewitter Aktivität im Umkreis von 40Km
  • Einschätzen der Entfernung zum Gewitter bis auf 1Km
  • Erkennt Wolke-Wolke und Wolke-Erde Blitzschläge
  • Erkennt Störsignale
  • Programmierbare Erkennungs-Level und Ansprech-Schwellen
  • Flexibel durch Standard Interface (SPI and I²C)

Datenblatt AS3935

 

Da sich diese Daten recht Interessant anhören, habe ich mich gleich mal auf die Suche nach den benötigten Komponenten gemacht und bin dabei auf diverse BreakOut Bords gestoßen. Da ich, was Antennentechnik betrifft, ein unbeschriebenes Blatt bin, habe ich mich entschlossen, ein fertiges BreakOutBord von CJMCU zu kaufen, das vom Design her sehr vielversprechend aussah.

Als Controller setze ich einen ATMEL ATMEGA16 ein, da hier schon Erfahrung bestand. In C habe ich dann einen kleinen "Treiber" geschrieben, der die Ansteuerung aus dem Programm vereinfacht, dazu später mehr....

Nachdem die I2C Hürde (Neuling) überwunden war, konnte der Chip über das Board angesprochen werden, wobei ich einige Stunden dem Anfängerfehler aufgesessen bin, dass am I²C-Bus kein Gerät die Adresse 0x00 haben darf. Auch die PullUp Widerstände sollten am Bus nicht vergessen werden, da die internen PullUps vom ATMEL viel zu hochohmig sind.

Eine kleine Herausforderung war eine Routine zum kalibrieren der Antennen Frequenz, die jedoch auch erfolgreich implementiert wurde.

Beim kalibrieren der Antenne bin ich jedoch auf ein Problem gestoßen, das sich nicht so leicht lösen lässt.

Kommentare   

0 # Helmut 2020-10-01 18:15
Nachdem bei meinem ersten Board auch die Kondensatoren falsch bestückt waren, hatte ich mir eines von einem anderen Hersteller bestellt. Auch dieses war falsch bestückt. Mit 820pF und 100pF parallel gehen nun beide.
Antworten | Antworten mit Zitat | Zitieren
0 # Helmut 2020-09-27 20:24
Da ist anscheinend mit den Einheiten etwas schief gegangen: in der Zeile über dem ersten LCD-Bild müssen die Einheiten der Kondis pF sein und nicht nF. Das ist Faktor 1000 zu groß!
Antworten | Antworten mit Zitat | Zitieren
0 # Jürgen Wagner 2020-09-27 21:38
Vielen Dank! Ist mir überhaupt nicht aufgefallen! Es wird eh Zeit, dass ich da mal weiter mache!

Danke!
Antworten | Antworten mit Zitat | Zitieren
   
© WagoTec.de