DSM PHP per SSH, Scipte mit bestimmter PHP Version ausführen

Wird auf die Diskstation per SSH zugegriffen und man muss dort PHP Scripte unter einer bestimmten PHP Version ausführen, stellt man fest, dass per SSH unter DSM 6.x standardmäßig die PHP Version 5.6 läuft.

Natürlich muss die benötigte PHP Version zuerst einmal über das Paket-Zentrum installiert werden.
Danach kann man die benötigte PHP Version wie folgt aufrufen:

PHP 5.6

php meinscript.php
Code-Sprache: PHP (php)

PHP 7.2

/var/packages/PHP7.2/target/usr/local/bin/php72 meinscript.php
Code-Sprache: PHP (php)

PHP 7.3

/var/packages/PHP7.3/target/usr/local/bin/php73 meinscript.php
Code-Sprache: PHP (php)

PHP 7.4

/var/packages/PHP7.4/target/usr/local/bin/php74 meinsript.php
Code-Sprache: JavaScript (javascript)
Consent Management Platform von Real Cookie Banner